View Single Post
  #1  
June 17th, 2011, 08:47 PM
AlanaIris AlanaIris is offline
Platinum Supermommy
Join Date: Oct 2007
Location: York, PA
Posts: 5,686
Hi ladies, I've never posted in here, but I don't really know who to ask about this. I had a baby in Oct. of last year and finally got BC in April and May. My cycles have always been regular, even while I was on BC. So, I went on the nuva ring at the beginning of April, followed the instructions, and put another in in the beginning of May. I took it out at the end of May...the 24th, got AF 5 days later on the 29th. I decided to not put in another ring afterwards because it made my period last for 8 days, I was always tired and I completely lost my sex drive. So, then today I used the bathroom and when I wiped there was bright red mixed in with my CM. Not just a few drops, but more than enough to be noticed without there being flow, if that makes sense. I'm only on CD20. I took a preg test this afternoon and it was a BFN. I'm still having the spotting when a wipe and a little bit on a liner. I don't know if this could be from coming off of the BC? Or if I'm ovulating late and it could be spotting from Oing?? I'm really hoping it's not the latter since DH and I DTD last night and the night before and we are so not ready for #3 just yet! Oh those heat of the moment moments! lol. At least my drive is back now though.
__________________

My Ovulation Chart




Mommy to Keagan - June 2008, Benny - October 2010 and Liam - June 2012
Reply With Quote