View Single Post
  #1  
January 29th, 2013, 11:40 AM
AnairaTTC AnairaTTC is offline
Newbie
Join Date: Jan 2013
Posts: 1
I wasn't sure whether I should post this in TTC or TWW, but here goes.
I've been having brown and very scant bleeding for 5 days now. There is literally nothing on my underwear, I don't even need a panty liner, but anytime I pee, it shows up on the toilet paper. Sometimes there is a tiny bit of pink, and a couple of days ago there was the smallest little dot of reddish color, but for the most part it's brown. My boobs have been hurting, although not tremendously. I've been having some little AF-like cramps for maybe a week, but nothing major. Usually AF and pre-AF cramps hurt like mad, not so this time. They're barely noticeable.

I started this brown, very light, bleeding on day 35 of my cycle. Typically, I tend to start AF around day 30-32, so that was slightly late.

I did have surgery two months ago and was told that due to the effects on anesthesia on the body, my next cycle may be delayed, which it was by 3 or 4 days. But aside from the last cycle being slightly delayed, it was normal. Normal color, flow, time span, symptoms. But this time is different. Weird color, sooooo scant, minimal cramping, and no sign of anything really increasing. That said, I also have no pg symptoms that I can tell so far. Boobs/nipples seem no bigger, no Montgomery's tubercles that I can see, and the only time I've thrown up recently was 18 days ago when I had a horrible migraine. I figured it was the pain that made me queasy.

I guess what I'm looking for is input and experiences involving implantation bleeding. I always thought it was a once a done thing, lasting maybe part of one day. But this is day 5 of my bleeding, plus it's at a strange time in the cycle for implantation, wouldn't you think? Starting on day 35. I always thought it was supposed to be 6-12 dpo, and this would have been more like 17 dpo.

Thoughts? Thank you so much in advance!
Reply With Quote