View Single Post
  #1  
July 15th, 2013, 01:37 PM
Brittanie's Avatar
Brittanie Brittanie is offline
just me
Join Date: Jul 2006
Location: Littleton, CO
Posts: 43,573
So, I had an anterior placenta with my Erin. Just about every appointment until until we got to the upper 20s in weeks they took a while to find her heartbeat (which, right after having a stillbirth, was REALLY hard on my nerves!). And then there was the whole not feeling as much movement thing.

Anyway, I've been feeling a little movement off and on, but not NEARLY as much as I was at this point with Patrick and Allison, and last appointment it took a minute or two to find the heartbeat, so I've been suspecting an anterior placenta this time too (they hadn't told me anything about my placenta).

So I brought it up at my appointment today, and I was right. Boo.

So then she tried for nearly 5 minutes to get the heartbeat. She said she could hear a couple swishes of movement (I couldn't), but no heartbeat. So she got the old ultrasound machine. Even then it took her a few more minutes to get a good shot of the heart (ARGH! I didn't realize how tense I was until I saw that flicker. Man!)


And then we tried to take a peek between the legs and no go. Rolo just REALLY didn't want to be bothered today. :/


So everything does look good. "Big" ultrasound scheduled for Aug 6th at 1pm, the day before I'm 20 weeks (and the day before the movers are supposed to come to pack up all our stuff!!).

I'm going to go take a nap.
__________________
Thanks to babydoll213 for the siggy! My kids' blog Cora's blog


Reply With Quote