Log In Sign Up

Kidney Infection and Spotting :(


Forum: Pregnancy and Motherhood After Loss

Notices

Welcome to the JustMommies Message Boards.

We pride ourselves on having the friendliest and most welcoming forums for moms and moms to be! Please take a moment and register for free so you can be a part of our growing community of mothers. If you have any problems registering please drop an email to boards@justmommies.com.

Our community is moderated by our moderation team so you won't see spam or offensive messages posted on our forums. Each of our message boards is hosted by JustMommies hosts, whose names are listed at the top each board. We hope you find our message boards friendly, helpful, and fun to be on!

Reply Post New Topic
  Subscribe To Pregnancy and Motherhood After Loss LinkBack Topic Tools Search this Topic Display Modes
  #1  
April 14th, 2011, 04:55 PM
OurSweetLabs's Avatar I LOVE My Boys!!
Join Date: Jul 2007
Location: South Carolina
Posts: 11,003
All Day long I have had crazy pressure and had to pee. So I called my Dr to get checked thinking that I had a bladder infection. I was wrong it's a Kidney infection. So when I got home I was wiping and noticed a little bit of pink so now I am in a panic. I know logically if I wasn't insane that I wouldn't have seen in the first place but now all I can think about it that pink.


Has anyone had a kidney infection and spotting and had everything turn out ok ?
__________________
Donna - Mom to David (4) and Asher
Proud Host of Cesarean Section Birth and Co Host of Blinkies R Us and the December 11 PR

Reply With Quote
  #2  
April 14th, 2011, 05:21 PM
hearts.0nfire's Avatar STPR lover
Join Date: Mar 2008
Location: Arkansas
Posts: 11,046
I never had spotting but I had 2 kidney infections last year when I was pregnant with my daughter and they really sucked. I hope the spotting stops soon and you feel better!
__________________

Reply With Quote
  #3  
April 14th, 2011, 05:23 PM
Platinum Supermommy
Join Date: Aug 2010
Posts: 6,057
Ugh, a kidney infection, that sounds awful hun!!! But just remember, your urinary system is NOT bound up with your reproductive system, so the kidney infection is not going to affect your uterus or anything like that. (Unless it spread to your whole body, and then boy you'd have problems!!!)

I bet the pink is actually from your urinary system infection, it could have been in your pee. Or it could just be some of the normal faint vaginal spotting which is common in early pregnancy. You could ask your doctor about it if you want, but personally I don't think it's a problem.

I hope the antibiotics work soon!!!
__________________



Reply With Quote
  #4  
April 14th, 2011, 06:52 PM
missy123's Avatar Platinum Supermommy
Join Date: Nov 2005
Location: Savannah GA
Posts: 13,417
I have never had a bladder infection. I hope you feel better soon, it does not sound fun.
__________________

Pregnancy Loss April 2009, September 2010
CP 10/2008, 1/3/11 {missing my babies every single day}Mommy to 4 Children - 3 boys ages 22, 21 and 18 & baby Scarlett
After 2.5 years TTC with 4 losses our Family was given the gift of Miss Scarlett
.
Do not ever give up hope...


Miss Scarlett... Our miracle girl still brings happy tears to my eyes.



Reply With Quote
  #5  
April 14th, 2011, 06:54 PM
JessP's Avatar Lovin life and family
Join Date: May 2009
Location: Washington
Posts: 22,034
Send a message via MSN to JessP Send a message via Yahoo to JessP
Ugh no fun. Sorry you have a kidney infection. I would think the spotting is from the pressure. Your cervix has lots of blood going to it right now. I would call the dr tomorrow just to help you feel better but I am going to think there is nothing to serious. Did they do an exam today? That can also cause spotting. Was it alot? Oh and you aren't crazy I check everytime I go to the bathroom. I check my panties and the TP.
__________________

Thanks .:Shortcake:. for my great siggie
http://skinny-jessi.blogspot.com/


Reply With Quote
  #6  
April 14th, 2011, 07:12 PM
8miraclez's Avatar Formerly Halfbaked
Join Date: Jul 2007
Posts: 7,472
Yes! I usually don't notice UTI's until it's in my kidneys and then I usually have some spotting. I've even had them so bad I was peeing blood. They really suck. Try not to worry and know that it is normal. Hang in there. I hope it clears up soon.
__________________


To read updates about our baby born with major birth defects, like our Facebook page
Reply With Quote
  #7  
April 15th, 2011, 12:08 PM
ohnicole's Avatar Platinum Supermommy
Join Date: Nov 2009
Posts: 5,756
Ugh- that sounds awful I hope you start feeling better soon!
__________________
Reply With Quote
  #8  
April 15th, 2011, 05:57 PM
OurSweetLabs's Avatar I LOVE My Boys!!
Join Date: Jul 2007
Location: South Carolina
Posts: 11,003
Thank you so much ladies !

I am glad to know that it is normal for a kidney infection. My back is hurting but thankfully I haven't had any more spotting.
__________________
Donna - Mom to David (4) and Asher
Proud Host of Cesarean Section Birth and Co Host of Blinkies R Us and the December 11 PR

Reply With Quote
  #9  
April 16th, 2011, 12:46 PM
mom2moose
Guest
Posts: n/a
I pee blood EVERY time I get a kidney or bladder infection. So, it was most likely that. I've never had one while pregnant though. Hope you feel better soon!!
Reply With Quote
Reply

Topic Tools Search this Topic
Search this Topic:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 05:26 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0