Log In Sign Up

35 Weeks, lost the plug, and doc's update


Forum: Pregnancy and Motherhood After Loss

Notices

Welcome to the JustMommies Message Boards.

We pride ourselves on having the friendliest and most welcoming forums for moms and moms to be! Please take a moment and register for free so you can be a part of our growing community of mothers. If you have any problems registering please drop an email to boards@justmommies.com.

Our community is moderated by our moderation team so you won't see spam or offensive messages posted on our forums. Each of our message boards is hosted by JustMommies hosts, whose names are listed at the top each board. We hope you find our message boards friendly, helpful, and fun to be on!

Reply Post New Topic
  Subscribe To Pregnancy and Motherhood After Loss LinkBack Topic Tools Search this Topic Display Modes
  #1  
April 17th, 2007, 01:21 PM
ypperin's Avatar Mega Super Mommy
Join Date: Aug 2006
Location: Vancouver Canada
Posts: 1,342
Well ladies, lost my mucus plug yesterday (at least started to). Didn't really act too concerned - these things can take weeks

Had a docs appt today, We're at 35 weeks, but I'm measuring 37 Someone pls tell me this baby is coming early.

Did the swab today - and I have to say my doc is so gentle, he does it even without the speculum Makes life much less uncomfortable! Course now, I'm about done, ready to have this baby outta me, and be in complete control of my body again.

Doc checked the cervix as well, but he didn't say anything, and of course I didn't ask, cause, well, been there done that. Baby is definitely head down though which is great, hopefully he stays put
__________________




Reply With Quote
  #2  
April 17th, 2007, 02:51 PM
Daniellea22's Avatar Platinum Supermommy
Join Date: May 2005
Location: New Jersey
Posts: 9,076
Send a message via AIM to Daniellea22
i hope he stays head down and you have him in the next few weeks!!
__________________
<div align="center">
</div>
Reply With Quote
  #3  
April 17th, 2007, 03:25 PM
Gaby&Emmy'sMama's Avatar aka NZ-Emma
Join Date: Aug 2005
Location: Christchurch, NZ
Posts: 56,619
ooo how exciting! LOL I lost my plug about 3 hours before my water broke, so I can't say that it took weeks for me - that said, I was 13 days - close to 14 days, overdue when I lost my plug & my water FINALLY broke. I do remember women from my PR lost their plug a few weeks before they were due, and went on to have their babes around about their due date..
__________________






Reply With Quote
  #4  
April 17th, 2007, 04:08 PM
jennifer97's Avatar Mega Super Mommy
Join Date: Oct 2006
Location: New Mexico
Posts: 1,878
Send a message via Yahoo to jennifer97
I've heard it can takes weeks as well after you've lost your plug....so here's hoping for an early delivery of a HEALTHY BABY!!!
__________________




<span style="color:#4169E1"><span style="font-family:Garamond">http://chasingfirefliesphotos.blogspot.com</span></span>

Reply With Quote
  #5  
April 18th, 2007, 05:36 AM
AndoriaC's Avatar Platinum Supermommy
Join Date: May 2006
Location: Western Pennsylvania
Posts: 10,199
Shoot for May 4th to have him - LOL - that's my birthday!
__________________
<div align="center">




Click For My Digital Scrapbook Blog</div>
Reply With Quote
  #6  
April 18th, 2007, 05:49 AM
ypperin's Avatar Mega Super Mommy
Join Date: Aug 2006
Location: Vancouver Canada
Posts: 1,342
Thanks for all the replies ladies With my history I will go into labour on May 22 Which will be extraordinarily frustrating, but hey, what's another couple of weeks with DH and my two lil princes before the house gets thrown into a whirwind
__________________




Reply With Quote
  #7  
April 18th, 2007, 07:23 AM
jessjillmama's Avatar ***Staying Positive***
Join Date: Sep 2004
Location: Coushatta, La
Posts: 7,892
Oh boy it sounds to me like you will go at least a little early. I lost my plug and never went into labor but I was induced so I may have I just don't really know.

Wishing you labor vibes soon!
__________________
Wife to Brian since October 2004, Mama too:
Jakob (May 12th 2004- Feb. 24th 2009 Had Joubert Syndrome RIP)
2 Baby beans lost
Ava Sept 14th 2007, Beaux Oct 3rd 2012
* Tubal reversal December 17th 2010



Reply With Quote
Reply

Topic Tools Search this Topic
Search this Topic:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 03:29 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0