Log In Sign Up

Two days late, neg prego tests? Am I or Not?


Welcome to the JustMommies Message Boards.

We pride ourselves on having the friendliest and most welcoming forums for moms and moms to be! Please take a moment and register for free so you can be a part of our growing community of mothers. If you have any problems registering please drop an email to boards@justmommies.com.

Our community is moderated by our moderation team so you won't see spam or offensive messages posted on our forums. Each of our message boards is hosted by JustMommies hosts, whose names are listed at the top each board. We hope you find our message boards friendly, helpful, and fun to be on!

Reply Post New Topic
  Subscribe To AIP Venting Place LinkBack Topic Tools Search this Topic Display Modes
  #1  
October 9th, 2011, 05:57 PM
Newbie
Join Date: Oct 2011
Posts: 1
I went off the pill in June after nine years. Last month I had some spotting on day 28, period on day 29 (Heavy day, two light days). Every other month, I've had noticeable, uncomfortable cramps for several days leading up to my period, as well as sore breasts and moodiness the day before. I had a tiny spot of blood yesterday (brown)(day 29), and the lightest pink streaks a couple times last night, but nothing since then. Only some slight aches that I would dismiss as normal back aches any other time (no cramps), and no breast tenderness at all this cycle. I was using OPKs and tested around days 12-15. I didn't get a positive result and skipped a few days, but had egg white discharge around day 18 and tested with a faint line (not a positive, according to the package, but something I noticed last month right before and after a positive), so I'm pretty sure I ovulated. If that's accurate, I would be 12ish DPO and I'm on day 30, 2 days late for my usual spotting and a day late for my period. BUT I tested on Wednesday (day 26), Saturday (day 29) with 2 tests, and today (day 30) with two tests, all first thing in the morning except the second one today. All are supposed to be the sensitive ones (20ml), and all have been negative. All are Aimstrip dip strips except for one yesterday that is an equate pee stick. That one had what seemed to be an evap line, according to the dozens of pics I looked up, no color and barely visible in bright light. So, where is my period or my positive prego test??? It's driving me nuts. Even if I did ovulate late when I think I did, the tests should be picking it up now, right?

Update: Day 31, some more LIGHT brown spotting (2 or 3 wipes worth), but that's it! Another neg prego test this a.m.

Last edited by olivia_NY; October 10th, 2011 at 04:50 PM. Reason: Update
Reply With Quote
  #2  
October 28th, 2011, 07:54 AM
Newbie
Join Date: Oct 2011
Posts: 5
update
Reply With Quote
Reply

Tags
am i pregnant , bleeding , conception , test

Topic Tools Search this Topic
Search this Topic:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 01:27 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0