Log In Sign Up

Have a question...


Forum: Fertility Charting

Notices

Welcome to the JustMommies Message Boards.

We pride ourselves on having the friendliest and most welcoming forums for moms and moms to be! Please take a moment and register for free so you can be a part of our growing community of mothers. If you have any problems registering please drop an email to boards@justmommies.com.

Our community is moderated by our moderation team so you won't see spam or offensive messages posted on our forums. Each of our message boards is hosted by JustMommies hosts, whose names are listed at the top each board. We hope you find our message boards friendly, helpful, and fun to be on!

Reply Post New Topic
  Subscribe To Fertility Charting LinkBack Topic Tools Search this Topic Display Modes
  #1  
April 18th, 2008, 08:11 AM
jenmommy's Avatar Mega Super Mommy
Join Date: Jan 2006
Location: South Carolina
Posts: 1,324
Ok, since my son was born 9 years ago...I have had very painful and heavy periods. ..I have been fertility charting for a while...and notice I do ovulate...sometimes late though...but usually every cycle...and my temps stay kind of flat after o..just higher.

My period is normally very heavy...and very painful with lots and lots of cramping especially back cramps...that go all the way down my legs...

well since about 2/24 which wierdly is around when I got a false positive on a hpt...my periods have been abnormally light and barely any cramps...I usually live on IB for 2 days of my most painful cramps...

I also was experiencing a wierd contracting feeling in my abdomen...finally on 3/23 I went to the doc and had an ultrasound done...the tech though was terrible...she constantly talked on the phone...and it constantly rang..though she apologized...my ovaries were easy to find but lopsided...transvaginally she couldn't get to my left ovary--it is way over by my hip...she said my right ovary was kind of in the middle and lower than the left..she got arterial blood flow out of them both though..

she saw no torsion...but she did see transabdominally a dominant follicle on my left ovary--I told her that's where I normally ovulate from...I told her I was about to have my period in 2 days...and she kind of questioned that..she asked me twice ..after I told her several times.."When did you say your next period was?" .I don't know if that's because she saw the dominant follicle or what?

anyways, I got an all clear on that ultrasound...but that feeling persists..I still don't know what the heck it is.I don't get it every day...and my last period was even lighter, and barely any cramps...

I am 28 years old...so getting up there in my age...I pray that I am still ovulating...because I found out that without ovulation your body does not really experience a period..only breakthrough bleeding...but I have all the symptoms of o...including ewcm, bb tenderness, and temp rise.

what could be going on??

Reply With Quote
  #2  
April 18th, 2008, 08:17 AM
Platinum Supermommy
Join Date: Mar 2008
Location: Maryland
Posts: 20,233
Did you talk to your doctor about the results? It sounds like the dominant follicle hadn't released yet which would make a true visit from AF highly unlikely. Do you have a chart link that we could look at? Have they done any blood work to check your hormone levels?
__________________
~Thanks Babydoll213 for my awesome siggie!~



Reply With Quote
  #3  
April 18th, 2008, 08:28 AM
ShawnaCAN's Avatar Platinum Supermommy
Join Date: Aug 2006
Location: Alberta, Canada
Posts: 11,397
Do you have a chart handy?
__________________
Reply With Quote
  #4  
April 18th, 2008, 09:33 AM
jenmommy's Avatar Mega Super Mommy
Join Date: Jan 2006
Location: South Carolina
Posts: 1,324
ok here is my chart...I have to tell you though I put the monitor in as peak for me...even though I really don't use one...because it is easier for me to monitor it by looking at that line...usually my o is confirmed when bbs get tender...and my ewcm disappears.

I did a little better charting my temps this cycle...because I was worried about the strange periods for me...

http://www.fertilityfriend.com/ttc/index.php

no, no bloodwork at all...when I went to the doc last visit...

I had a history taken, and pregnancy test given...and it was -, told them don't bother, cause I'd done it before and it was -.

oh, and my endometrial thickness was consistent with right before period 13 mm. she did say that was normal for the time of the month I was in...
Reply With Quote
  #5  
April 18th, 2008, 09:45 AM
Jennifer-in-Italy
Guest
Posts: n/a
that link takes me to my chart. To share, go on the left hand side to sharing and configure home page.
Reply With Quote
  #6  
April 18th, 2008, 09:52 AM
Platinum Supermommy
Join Date: Mar 2008
Location: Maryland
Posts: 20,233
You need to set up a home page and provide us with the link it gives you for your home page.
__________________
~Thanks Babydoll213 for my awesome siggie!~



Reply With Quote
  #7  
April 18th, 2008, 10:09 AM
jenmommy's Avatar Mega Super Mommy
Join Date: Jan 2006
Location: South Carolina
Posts: 1,324
Ok, I think I did this right...

here you go

http://www.fertilityfriend.com/home/116ea4
Reply With Quote
  #8  
April 18th, 2008, 10:19 AM
ShawnaCAN's Avatar Platinum Supermommy
Join Date: Aug 2006
Location: Alberta, Canada
Posts: 11,397
Have you any tests to rule out endometriosis? U/S can often miss it, it's usually diagnosed with a laproscopic procedure. Everything with your chart looks good, but the incredibly painful menses is making me wonder about endo.
__________________
Reply With Quote
  #9  
April 18th, 2008, 10:21 AM
jenmommy's Avatar Mega Super Mommy
Join Date: Jan 2006
Location: South Carolina
Posts: 1,324
so if I did? Could I not have it anymore..due to the pain stopping?
Reply With Quote
  #10  
April 18th, 2008, 10:24 AM
Platinum Supermommy
Join Date: Mar 2008
Location: Maryland
Posts: 20,233
Did you have an epidural when you were having DS? I had one both times and the first time it went totally smooth, but the second time they waited too long and had trouble putting it in right. The epidural itself caused a lot of pain in my hips and ever since then when AF first shows up I get pain in my pelvis, hips, and upper legs. I also have occasions where I get cramps that feel almost as bad as my labor pains did. I've wondered ever since then if it's because they had trouble with the epidural.

I'm just wondering if that's another possibility for you to ask your doctor about.
__________________
~Thanks Babydoll213 for my awesome siggie!~



Reply With Quote
  #11  
April 18th, 2008, 10:36 AM
ShawnaCAN's Avatar Platinum Supermommy
Join Date: Aug 2006
Location: Alberta, Canada
Posts: 11,397
Quote:
so if I did? Could I not have it anymore..due to the pain stopping?[/b]
Oh I'm sorry! I missed the part about the pain being gone now. It's really tough to say, could be any number of things. A cyst that resolved itself perhaps. As for the dominant follicle at this stage of your cycle, I wonder if she saw the Corpus Luteum and mistook it for a follicle? It's my understanding that u/s technicians aren't actually qualified to interpret the images, just to take them.

__________________
Reply With Quote
  #12  
April 18th, 2008, 10:55 AM
jenmommy's Avatar Mega Super Mommy
Join Date: Jan 2006
Location: South Carolina
Posts: 1,324
she said you have a dominant follicle in your left ovary...do you know what I mean by dominant follicle? I figured that was the follicle that would rupture when I ovulated..so I said yes..I told her I have had a history of a 3 cm cyst on my ovary....she said when they are less than 2 cm they call them follicles...she also said I had smaller follicles in my right ovary...

even my report which was read by the technologist says dominant follicle in left ovary.

I don't know..I don't care...as long as you think I am still ovulating...I am getting fat...I am the heaviest I've ever been, but my appetite is crazy...and I have little stimulation to exercise...at least I know I don't have pcos...

endo does run in my family...

with James I had an emergency c-section and had to have a spinal. since then I have sciatica so that could be attributing to it...really don't know..
Reply With Quote
  #13  
April 19th, 2008, 01:56 AM
Jennifer-in-Italy
Guest
Posts: n/a
cysts and follicles are COMPLETELY different. Call your doctor and insist on seeing them, and if they won't get you in, ask for a different doctor. The u/s tech should NOT have been talking about the stuff with you without your doctor being there. Every time I have had my ultrasounds the only thing the tech will tell me is if she sees cysts that are too large or not, and that's ONLY because my doc okay'd that.
Reply With Quote
  #14  
April 19th, 2008, 05:22 AM
Platinum Supermommy
Join Date: Mar 2008
Location: Maryland
Posts: 20,233
Unless a tech is given permission by your doctor they are not supposed to talk about the things that they do or do not see. That tech clearly had no idea what she was talking about. You need to talk to your doctor asap to find out what's going on. Good luck!
__________________
~Thanks Babydoll213 for my awesome siggie!~



Reply With Quote
  #15  
April 19th, 2008, 10:13 AM
jenmommy's Avatar Mega Super Mommy
Join Date: Jan 2006
Location: South Carolina
Posts: 1,324
hmmm...let me throw in I don't go to docs for just anything...

you know what, if I'm not in pain, I'm just going to let it go...there were no huge masses anywhere...so maybe it's just intestinal...and I know if something really gets screwed up there...I will definitely know that...

the tech was really chatty, but sweet, the phone calls were annoying the hell out of me though...

thanks ladies for your support...so my chart looks ok then..good. i just knew i ovulated...my nips are so sensitive...im pretty sensitive to that stuff...
Reply With Quote
Reply

Topic Tools Search this Topic
Search this Topic:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 09:00 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0