Log In Sign Up

lost my baby at 14 weeks


Welcome to the JustMommies Message Boards.

We pride ourselves on having the friendliest and most welcoming forums for moms and moms to be! Please take a moment and register for free so you can be a part of our growing community of mothers. If you have any problems registering please drop an email to boards@justmommies.com.

Our community is moderated by our moderation team so you won't see spam or offensive messages posted on our forums. Each of our message boards is hosted by JustMommies hosts, whose names are listed at the top each board. We hope you find our message boards friendly, helpful, and fun to be on!

Reply Post New Topic
  Subscribe To Labor and Mini Labor Experiences LinkBack Topic Tools Search this Topic Display Modes
  #1  
April 3rd, 2010, 09:50 AM
Mommy2Amara&Kayori's Avatar Platinum Supermommy
Join Date: Aug 2006
Location: Missoula, Mt
Posts: 17,100
Send a message via Yahoo to Mommy2Amara&Kayori
Friday 9:45pm I started spotting. I called my midwife the next morning as I was still spotting. She didn't seem to worried because it was only spotting, wasn't bright red, and I had no pain. I was told to monitor it and if anything changed to call her. I spotted the whole day saturday, but still no pain and it wasn't bright red. Sunday at 5:45pm I started having period like cramping. A few minutes later I felt a pop and I had a gush of water that was slightly red run down my legs and on the floor. I think my water broke. I sat on the toilet and the contractions got worse. Not anything like full term labor, but it hurt bad. I felt the urge to push and I pushed out a huge clot. Contractions and clots lasted until 10pm. The next day I felt like I had bad period cramping. At noon I started getting the contractions again and I had the urge to push, I went to the bathroom and pushed, I screamed out in pain the contraction hurt so bad, I pushed out the placenta, I had to help pull it out some and I looked at it pretty good, it was deffinately the placenta. I had bad cramping for a few hours and the next day I felt fine and I am bleeding lightly. But I am heart broken. I lost my baby. I was 14 weeks exactly.

__________________
Jenny - Wife to James - Mommy to Amara(6) and Kayori(4)
missing our Angels 2001, 2005, and 2010

Expecting our 3rd bundle of joy!


Reply With Quote
  #2  
April 19th, 2010, 09:47 PM
Super Mommy
Join Date: Jan 2010
Posts: 590
I'm so sorry for you loss. My baby was 14 1/2 wks but I didn't find out until the day of out u/s. The baby had die. I had to deliver it or get a D & E so I chose the deliver. I know exactly how you feel. I am so sorry mine was in May of 2007 so just take a easy and it does get easier.
__________________

Reply With Quote
Reply

Topic Tools Search this Topic
Search this Topic:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 08:03 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0