Log In Sign Up

blood in urine


Welcome to the JustMommies Message Boards.

We pride ourselves on having the friendliest and most welcoming forums for moms and moms to be! Please take a moment and register for free so you can be a part of our growing community of mothers. If you have any problems registering please drop an email to boards@justmommies.com.

Our community is moderated by our moderation team so you won't see spam or offensive messages posted on our forums. Each of our message boards is hosted by JustMommies hosts, whose names are listed at the top each board. We hope you find our message boards friendly, helpful, and fun to be on!

Reply Post New Topic
  Subscribe To TTC after recurrent loss LinkBack Topic Tools Search this Topic Display Modes
  #1  
March 19th, 2007, 08:51 PM
amyproffitt's Avatar Regular
Join Date: Mar 2007
Posts: 5
Does anyone know why i would have alot of blood in my urine(250+) when tested..i have had 3 m/c and all 3 showed that much blood when i first found out i was pregnant but the babies never implanted i dont know if that blood has something to do with m/c or something else is doing it only thing dr found was chronic uterus infection but not for sure if thats the cause or not either...
Reply With Quote
  #2  
March 19th, 2007, 08:57 PM
Rina42308's Avatar Mega Super Mommy
Join Date: Mar 2005
Location: CA
Posts: 2,991
Did you recently m/c? Could it be a bladder/kidney infection? Are you experiencing any other kind of pain with it? I know blood in urine is not considered "normal" so I would definitly f/u with your Dr. Let us know how you are.
__________________
Mommy to miracle baby 4/23/08 and four babies in heaven:lost 3/22/05 edd 10/28/05, lost 5/25/05 edd 12/26/05, lost 1/31/06 edd 9/19/06

"Never doubt that a small group of thoughtful, committed citizens can change the world; indeed, it's the only thing that ever has." -Margaret Mead
Reply With Quote
  #3  
March 19th, 2007, 09:12 PM
amyproffitt's Avatar Regular
Join Date: Mar 2007
Posts: 5
Hey Thanks for the comment yes wed. will be 4wks since my d&c..ive lost 3 over a year...when the dr done test it came back as i had uti so thats what he said it was but sometimes i wonder if thats the whole reason its there i could understand traces of blood being a uti cause thats the normal...
Reply With Quote
  #4  
March 20th, 2007, 07:22 AM
4iris's Avatar Platinum Supermommy
Join Date: May 2006
Location: Midwest
Posts: 10,732
Definitely sounds like an infection in your bladder and/or kidneys. And an infection left untreated can cause problems with a pg. I've started every pg with positive results for both pg and uti/kidney infection. Not fun. I hope your doc is treating you for it and will be watching for signs the next time you're pg.
__________________
Do not sorrow; the joy of the Lord is your strength." Neh. 8:10
Reply With Quote
  #5  
March 20th, 2007, 08:17 AM
Rina42308's Avatar Mega Super Mommy
Join Date: Mar 2005
Location: CA
Posts: 2,991
Amy I am sorry for your loss. I've lost 4 babies as well. I would assume your Dr gave you antibiotics right? If not be sure to request some, it's important to clear those kind of infections up as soon as you can. take care.
__________________
Mommy to miracle baby 4/23/08 and four babies in heaven:lost 3/22/05 edd 10/28/05, lost 5/25/05 edd 12/26/05, lost 1/31/06 edd 9/19/06

"Never doubt that a small group of thoughtful, committed citizens can change the world; indeed, it's the only thing that ever has." -Margaret Mead
Reply With Quote
  #6  
March 20th, 2007, 07:40 PM
amyproffitt's Avatar Regular
Join Date: Mar 2007
Posts: 5
Hey sry to hear about your losses maybe one day it will be our turn...yea dr did give me antibiotics and froze my cervix i hope this will help i think i need to give my body more time to heal this time around i always waited like 2 months then try again maybe i will wait a little while longer the dr said he didnt wont me to get pregnant for 3 months so i will wait that long or maybe little longer not for sure but we will see waiting is rough!
Reply With Quote
  #7  
March 21st, 2007, 10:26 PM
Rina42308's Avatar Mega Super Mommy
Join Date: Mar 2005
Location: CA
Posts: 2,991
Waiting is really rough I know. I've heard some contradicting statements from Dr's about waiting 3 months. I have heard things like 3 months is a good amount of time for the lining to build back up (for implantation) but then I've heard that Dr's just say that because they think that's a good amount of time to heal emotionally (goes to show they don't realize it takes a lot longer then 3 months for emotions to get any better after a m/c!) I think if you feel your body needs it then it's best to follow your gut. I wish you the best. hope you're at least feeling better physically soon!
__________________
Mommy to miracle baby 4/23/08 and four babies in heaven:lost 3/22/05 edd 10/28/05, lost 5/25/05 edd 12/26/05, lost 1/31/06 edd 9/19/06

"Never doubt that a small group of thoughtful, committed citizens can change the world; indeed, it's the only thing that ever has." -Margaret Mead
Reply With Quote
Reply

Topic Tools Search this Topic
Search this Topic:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 12:43 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0