Log In Sign Up

Trying to find a way through this brand new infertility maze


Forum: Trying to Conceive

Notices

Welcome to the JustMommies Message Boards.

We pride ourselves on having the friendliest and most welcoming forums for moms and moms to be! Please take a moment and register for free so you can be a part of our growing community of mothers. If you have any problems registering please drop an email to boards@justmommies.com.

Our community is moderated by our moderation team so you won't see spam or offensive messages posted on our forums. Each of our message boards is hosted by JustMommies hosts, whose names are listed at the top each board. We hope you find our message boards friendly, helpful, and fun to be on!

Reply Post New Topic
  Subscribe To Trying to Conceive LinkBack Topic Tools Search this Topic Display Modes
  #1  
March 22nd, 2011, 10:59 AM
Veteran
Join Date: May 2010
Posts: 210
I'm wondering if any of you could help me and give me some ideas on what's going on! Lots of info - I hope it's not too confusing!
  • I'm on day 32 of my cycle of a normally 24-25 day cycle, and still no period.
  • 3 HPT big fat neg.
  • Ever since day 24, I've been feeling heavy and slightly crampy in my uterus.
  • My progesterone was tested on days 24 and 26, and both were <0.5. Low low low for this time in the cycle.
  • I had EWCM off and on up till day 28. Is this estrogen dominance in the absence of progesterone?
  • My period was also late 2 cycles ago, back in December, finally appearing on day 31. This is all brand new, having hiccups in my cycles.
  • ALSO - in "normal" cycles with a period, I get positive OPK, and sometimes it is positive for several days. As a general rule, I am having my period only a week after getting that first positive. My Gyno -insists- that ovulation occurs 14 days prior to period and that my tests are wrong. I don't think so - I think something's wrong with me, and I think it's tied to the low progesterone.
So, I'm anovulatory this month, and this is probably at least the second time it's happened. My Gyno will put me on Clomid for 5 days once I reach day 5 of my cycle. Day 12 will be an ultrasound to find new follicle. If it is >18mm, she will start me on hCG. Then day 26, I will start on progesterone suppositories.

Questions: If I totally skip my period this month, can I still start this treatment plan on the presumed day 5 (which would have been like a couple days ago), assuming everything's going to ovulate like normal next cycle? Or do I have to wait till I bleed and lose out on a month of TTC?

Any ideas what all could be going on with me? Why almost 0 progesterone? If it is because I did not ovulate, why did I not ovulate? I had a cold earlier this month, and am still coughing a lot. Would that prevent ovulation?

Is there any chance I have an ectopic pg, given all these symptoms?

Also, I was on Yasmin for 2-3 years, and quit that about 8 months ago. Any chance that messed me up hormonally? Pre-BC, my cycles were normal 28 days, long periods, with baaaad cramps. Post-BC, my cycles are average 24 days, milder cramps, and shorter periods.

Thanks ladies!
Reply With Quote
  #2  
March 22nd, 2011, 12:38 PM
ccartanddesign's Avatar With Faith
Join Date: Dec 2010
Posts: 997
Hi,
I know that once you ovulate the corpus luteum bursts and releases progesterone. So being annovulatory could definitely be the reason for low low Progesterone.

That's the only question I can answer for you. I hope this helps.
__________________
Me-38 DH-38. TTC #1 since August 2009
2/2011 - IUI + Femara + HCG trigger and Progesterone injection BFN
3/2011 - IUI + Femara + HCG trigger and Progesterone injection
4/2011 - not doing IUI - DH out of town
5/2011 - IUI with Femara and HCG trigger. In hospital due to infection from IUI.
Took a break from all meds this summer.
9/2011: - Start with new RE - testing begins.
10/2011: - Hysteroscopy - determine tubes are blocked.
10/2011 : - Laparoscopy - clip blocked tubes, determine right ovary is adhered to pelvic wall, cut adhesions
11/24/2011: IVF cycle #1 begins. Start stims.
12/2/2011: End stims. HCG trigger.
12/4/2011: Egg Retrieval. 9 eggs, only 1 embryo.
12/7/2011: Transfer.
12/20/2011: IVF #1 failed.
1/16/2012: IVF #2 first scan
"Humanly speaking, it is impossible. But with God everything is possible." Matt. 19:26
Reply With Quote
  #3  
March 22nd, 2011, 01:05 PM
Veteran
Join Date: May 2010
Posts: 210
Well I didn't understand the mechanism of progesterone release, so that does help. Still don't know why I didn't ovulate, if that's what happened here.

If I have a period, does that mean I did for sure ovulate that month? Do I build up a lining at all if I didn't ovulate (and if not, then why the full, achy feeling in there..)

We've been TTC for 7 months now.
Reply With Quote
Reply

Topic Tools Search this Topic
Search this Topic:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 03:29 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0