Log In Sign Up

Mucus Plug Already???


Forum: Home Birth

Notices

Welcome to the JustMommies Message Boards.

We pride ourselves on having the friendliest and most welcoming forums for moms and moms to be! Please take a moment and register for free so you can be a part of our growing community of mothers. If you have any problems registering please drop an email to boards@justmommies.com.

Our community is moderated by our moderation team so you won't see spam or offensive messages posted on our forums. Each of our message boards is hosted by JustMommies hosts, whose names are listed at the top each board. We hope you find our message boards friendly, helpful, and fun to be on!

Reply Post New Topic
  Subscribe To Home Birth LinkBack Topic Tools Search this Topic Display Modes
  #1  
February 11th, 2008, 09:42 AM
Mommy2Amara&Kayori's Avatar Platinum Supermommy
Join Date: Aug 2006
Location: Missoula, Mt
Posts: 17,100
Send a message via Yahoo to Mommy2Amara&Kayori
I felt weird all day yesterday. In the morning it was uncomfortable for me to stand for long periods of time. Later in the day I started having this horrible pain in my right side. It felt kind of like a side ache does but 100% worse. I only got this pain if I was walking or standing, so I tried to sit or lay as much as possible. Well that pain lasted for about 2 hours. It feels like the baby is lower too. I have more of a pressure down there now. Well when I went to work today my underwear felt wet so I went to the bathroom and wiped. I got a big glob of clear musus. It was really thicker then any discharge I have had before. I think it may have been my mucus plug. Should I be worried? I feel fine today. I slept fine with no pain and I have had no pain today.
__________________
Jenny - Wife to James - Mommy to Amara(6) and Kayori(4)
missing our Angels 2001, 2005, and 2010

Expecting our 3rd bundle of joy!


Reply With Quote
  #2  
February 11th, 2008, 10:19 AM
4boys
Guest
Posts: n/a
I guess it could have been. I usually start losing mucus like that around 34-35 weeks and I keep losing it right up until delivery which is always more than a month later. If it was your plug, it is possible for it to grow back, so it doesn't necessarily mean you are close to labor. I'm glad the pain has stopped, that's a good sign. I would mention it to your midwife though, just in case. Hope this is helpful.
Reply With Quote
  #3  
February 11th, 2008, 11:40 AM
Mommy2Amara&Kayori's Avatar Platinum Supermommy
Join Date: Aug 2006
Location: Missoula, Mt
Posts: 17,100
Send a message via Yahoo to Mommy2Amara&Kayori
Quote:
I guess it could have been. I usually start losing mucus like that around 34-35 weeks and I keep losing it right up until delivery which is always more than a month later. If it was your plug, it is possible for it to grow back, so it doesn't necessarily mean you are close to labor. I'm glad the pain has stopped, that's a good sign. I would mention it to your midwife though, just in case. Hope this is helpful.[/b]

Thanks for your reply

I have read that it is possible to fall out and re grow also. It was very very thick and tinged yellow but still some what see through. I hope my pain stays away too.
__________________
Jenny - Wife to James - Mommy to Amara(6) and Kayori(4)
missing our Angels 2001, 2005, and 2010

Expecting our 3rd bundle of joy!


Reply With Quote
  #4  
February 11th, 2008, 01:28 PM
*Jackie*
Guest
Posts: n/a
yes, they fall re-grow.... fall & then re-grow etc..
Reply With Quote
  #5  
February 13th, 2008, 11:28 AM
ragmama's Avatar Platinum Supermommy
Join Date: Aug 2007
Location: Southern VA
Posts: 40,025
Glad you're feeling better now...just ditto the others on that one. I never saw the first hint of it with Rachael, but had several "what the heck?" moments with Amelia.
__________________
Kristin
mom to Rachael, 10 ~ Milly, 6 ~ foster mom (waiting on the next call)
Reply With Quote
Reply

Topic Tools Search this Topic
Search this Topic:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 05:31 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0