Log In Sign Up

Generic vs. Name Brand Clomid and Ovulation Day


Forum: Trying to Conceive with Medical Assistance

Notices

Welcome to the JustMommies Message Boards.

We pride ourselves on having the friendliest and most welcoming forums for moms and moms to be! Please take a moment and register for free so you can be a part of our growing community of mothers. If you have any problems registering please drop an email to boards@justmommies.com.

Our community is moderated by our moderation team so you won't see spam or offensive messages posted on our forums. Each of our message boards is hosted by JustMommies hosts, whose names are listed at the top each board. We hope you find our message boards friendly, helpful, and fun to be on!

Reply Post New Topic
  Subscribe To Trying to Conceive with Medical Assistance LinkBack Topic Tools Search this Topic Display Modes
  #1  
May 27th, 2009, 11:42 AM
irunpink's Avatar Sophie
Join Date: Oct 2008
Location: TX
Posts: 726
This is really weird, but I took generic clomid (serophene?) last month and felt like crap, had horrible ovary pain, felt myself ovulating, ovulated on day 16 and had bad migraines. This month I had to pick up my meds somewhere else and they gave me name brand Clomid but this time...I didn't get half as many headaches or side-effects, haven't had hardly any ovary pain and have no sign of ovulating!! Last month I was also really dry around this time, this time around I'm not dry at all.

Last month I used a digital OPK (clear blue, the $200 monitor) and I had high fertility for about 4 days before having one day of peak fertility (peak fertility = day of ovulation). This month I've had zero days of high fertility so far . Even though I was dry for awhile before ovulating, when I did O I had ewcm. Like I said, this time I'm not dry at all but don't have EWCM.

What's going on ? Could there be a difference or is this just my body going crazy?
__________________

Thank you, *Kiliki*, for my sweet siggy!



Reply With Quote
  #2  
May 27th, 2009, 12:24 PM
KMH KMH is offline
TTCMA Cheer Captain
Join Date: Sep 2008
Location: right of center
Posts: 19,122
Hmmm...there shouldn't be any difference between the generic and the name-brand. My first month I was given the generic, 25mg, and didn't ovulate. My second month I got 50mg of the name-brand, and I ovulated! The side effects were similar, so I'm pretty sure it was the dose, and not the source of the pills that made the difference. Are you on the exact same dose? Are you taking it at the same time of day that you took it last month?
__________________


Melissa & DH
IVF babies Claire (3), Abigail (1) and George (1)

Reply With Quote
  #3  
May 27th, 2009, 12:33 PM
irunpink's Avatar Sophie
Join Date: Oct 2008
Location: TX
Posts: 726
Thanks for your response, Melissa . It was the same dose, I took it at the same time (at night) but started it a few days later. Last month, I started it 5 days after the first day of spotting, this month I waited until 5 days after actually bleeding. I'm only on cd 14...so I'm keeping my fingers crossed. :/
__________________

Thank you, *Kiliki*, for my sweet siggy!



Reply With Quote
  #4  
May 27th, 2009, 12:42 PM
KMH KMH is offline
TTCMA Cheer Captain
Join Date: Sep 2008
Location: right of center
Posts: 19,122
The timing could be making the difference...hope it is a good difference and that it works!!
__________________


Melissa & DH
IVF babies Claire (3), Abigail (1) and George (1)

Reply With Quote
  #5  
May 27th, 2009, 04:25 PM
stefler's Avatar Super Mommy
Join Date: Feb 2009
Location: Whitby, Ontario (Canada)
Posts: 546
I always took generic, always same dose and same cycle days .... my s/e were worse with my first round and o varied from cd 12 - 17. I guess it just depends on how your body responds in a given cycle. Good luck!!!
__________________
Me(Steph): 30, Endo DH(Scott): 39, perfect swimmers
DD (Lauren): August 2002
TRYING FOR #2 SINCE JULY 2006
Referred to RE July 2008:
1st cycle: natural - cancelled due to drop in E2
2nd cycle: 100mg Clomid day 3-7, Ovidrel & TI -
3rd cycle: 100mg Clomid day 3-7, Ovidrel, IUI -
4th cycle: natural (clinic closed over holidays) -
5th cycle: 150 IU Bravelle day 3-10, Ovidrel, IUI -
6th cycle: no meds - Lap. March 3/09 - endo removed from left ureter, dye test - tubes all clear!
7th cycle: 100mg Clomid day 3-7, Ovidrel, TI -
8th cycle: 150IU Bravelle day 3-10, Ovidrel, IUI - OHSS,
9th cycle: natural/MA Break -
10th cycle: last cycle w/MA - 125IU Puregon Day 3-5, 100IU Day 6-11, Trigger, IUI + TI -
finished with M/A, NTNP from now on....

Reply With Quote
Reply

Tags
clomid , late ovulation , ovulation

Topic Tools Search this Topic
Search this Topic:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 05:29 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0