Log In Sign Up

*snif snif*...still haven't O'd


Forum: Trying to Conceive with Medical Assistance

Notices

Welcome to the JustMommies Message Boards.

We pride ourselves on having the friendliest and most welcoming forums for moms and moms to be! Please take a moment and register for free so you can be a part of our growing community of mothers. If you have any problems registering please drop an email to boards@justmommies.com.

Our community is moderated by our moderation team so you won't see spam or offensive messages posted on our forums. Each of our message boards is hosted by JustMommies hosts, whose names are listed at the top each board. We hope you find our message boards friendly, helpful, and fun to be on!

Reply Post New Topic
  Subscribe To Trying to Conceive with Medical Assistance LinkBack Topic Tools Search this Topic Display Modes
  #1  
October 13th, 2007, 08:56 PM
Mega Super Mommy
Join Date: Feb 2007
Posts: 3,013
CD 16 and still haven't o'd yet. And lately I haven't been seeing much of eggwhites. I used to get lots, but since I taken Clomid, I would say that the amount has decreased. I do still see some, but not a lot of it. And only visible after I empty my stool (sorry tmi). I just hope that if I do O this cycle, I will still get healthy fertile CM, even though it may not be an abundence of it.
Reply With Quote
  #2  
October 13th, 2007, 10:26 PM
*Melissa*'s Avatar Mega Super Mommy
Join Date: Jan 2007
Location: Oregon
Posts: 4,708
Send a message via MSN to *Melissa*
hang in there sweetie!!! I don't think i even o'd until cd 21 and i had hardly any ewcm, but it still happened for me! you never know so just keep bd'ing and hope for the best!!!
Reply With Quote
  #3  
October 14th, 2007, 09:36 AM
LaniR304's Avatar Regular
Join Date: May 2007
Location: Arizona
Posts: 92
I'm no expert, but your CD16 from this cycle looks like it matches with your CD42 from the previous cycle. Hang in there! I'm on CD19 and still hoping I will O--the first time I O'd on clomid it was CD25, so I st!ill have some hope left!
What was your temp from this morning?

Hang in there!
__________________


TTC #1 since February 2007
Clomid #1: 50mg--no labs drawn
Clomid #2: 50 mg, Progesterone Level: 0.6
Clomid #3: 100mg--no labs drawn
Clomid #4: 100mg, Progesterone Level: 6.6
Clomid #5: 150mg, Progesterone Level: 10.8
Break from Clomid due to finding out DH S/A showed poor morphology (0-4%).
Repeat S/A on 2/7 and Urologist appointment on 2/21: Results showed abnormally high sperm count, so when that is taken into consideration, the morphology is normal.
First RE appointment: 3/17

Reply With Quote
  #4  
October 14th, 2007, 02:24 PM
Astrid's Avatar Platinum Supermommy
Join Date: Oct 2005
Location: Houston, TX
Posts: 27,408
I had almost non-existant CM when on Clomid. I bought PreSeed to help out both us & the spermies when BD. Try not to stress that you haven't already Oed. Are you temping or using OPKs to follow your cycle? If not, I would highly recommend doing either or both.
__________________
Check out hEvan @ http://www.etsy.com/store/hEvan
for some great handmade items.
All proceeds go to a family struggling w/ infertility!



Reply With Quote
Reply

Topic Tools Search this Topic
Search this Topic:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 05:49 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0