Log In Sign Up

Need some advice/Do I retest or wait?


The Two Week Wait Escape

Come on in to help pass the time until you test!

Welcome to the JustMommies Message Boards.

We pride ourselves on having the friendliest and most welcoming forums for moms and moms to be! Please take a moment and register for free so you can be a part of our growing community of mothers. If you have any problems registering please drop an email to boards@justmommies.com.

Our community is moderated by our moderation team so you won't see spam or offensive messages posted on our forums. Each of our message boards is hosted by JustMommies hosts, whose names are listed at the top each board. We hope you find our message boards friendly, helpful, and fun to be on!

Reply Post New Topic
  Subscribe To The Two Week Wait Escape LinkBack Topic Tools Search this Topic Display Modes
  #1  
May 15th, 2011, 01:52 AM
Newbie
Join Date: May 2011
Posts: 7
I realize this gets asked a lot and I promise I'm not a troll just a very very confused somewhat worried woman who likes to panic about everything! I've read SOOO many articles already and have been driving myself nuts with research so I'd really appreciate any opinions/advice!

So here's my situation:
I regularly get my period every 28 days but in April I got it early (Due to stress) It was scheduled to arrive on 4/15 but I got it on 4/10. My doctor suggested I stop taking the remaining hormonal pills and then start a new pack on the same day my new period would start. Well I tried this and my partner and I had intercourse on 4/20 (while I was back on the pill for about 8 days) and then i got another quasi period (No new blood just light brown discharge and not noticeable except on toilet paper) on 4/23. This lasted for approx 4-5 days. I again called the DR and she told me to just stop taking the pills until I get a period naturally than restart another pack. I believe my period is now late since what i believe was my period occurred on 4/10 and I haven't had one since beyond the light brown discharge. Am I pregnant/do I have like some massive tumor? I have noticed a little white discharge and I took a HPT on the first day I was late and it was negative? (I've read this may have been too early to test. I used clear blue easy)

Summary:
I've missed my natural period date before the breakthrough bleeding
I've also missed the date of my next period from the date of my break through/early period
Should I take a second test now that it's been another week since the first neg result or do you think perhaps my body is just going to sync up with the brown discharge and wait to see if I get an actual period 28 days from that date? (I'd be due next Friday/one week from now)
Sorry for being graphic!

I haven't really had any symptoms like breast soreness/changes but I've noticed mood instability and I've peed like 8 times in the last 5 hours (Could be psychosomatic too lol) On the date I should have had my period based on the breakthrough date I did have some cramps which I thought was AF coming to visit again but nada) (SORRY, I may have posted in wrong area! Feel free to delete one of the double post admins!)
Thanks again!

Last edited by Chrissy2005; May 15th, 2011 at 02:04 AM.
Reply With Quote
  #3  
May 19th, 2011, 02:18 AM
Newbie
Join Date: May 2011
Posts: 7
Well I chickened out on retesting and over the last week I've noticed some other symptoms (maybe it's all in my head!) but I have been freezing constantly and have had so many false alarms as to AF arriving... You know that feeling you get where you just know you're about to have your period be it it feels a little wet down there or the cramps, yeah have had that feeling like 4-5 times now and still nothing. Also my appetite has been off the chart... I swear I'm not starving myself but I've started to feel like I haven't eaten in days at times. Guess I'll know for sure come Saturday morning!
Reply With Quote
  #4  
May 19th, 2011, 08:27 AM
Newbie
Join Date: May 2011
Posts: 5
good luck hope it's your
Reply With Quote
  #5  
May 19th, 2011, 01:53 PM
Newbie
Join Date: May 2011
Posts: 2
Just a note to you... I too have had a similar situation. I had my normal 28 day thing, then two weeks later another lighter "period" if you want to call it that. Seems like the pill just didn't do it's job recently. Now here I am four days after the day I should have gotten my regular period. No period, but plenty of cramps. Not sure if my body has reset" itself to a later cycle or if I am pregnant. At any rate, I hear ya!
Reply With Quote
  #6  
May 24th, 2011, 03:40 PM
Newbie
Join Date: May 2011
Posts: 7
Well I look forward to joining you guys when the time is right On the plus side while I'm a bit disappointed I got my lovely AF 28 days to the discharge so I am not infact pregos. It did open up a good dialogue with me and the DH though. Plus I just got accepted to an amazing doctoral program and am only 26 so there's still time to worry about my BFP. Thanks so much for the support and reassurance though! Good luck everyone else!!
Reply With Quote
  #7  
May 25th, 2011, 07:59 AM
Veteran
Join Date: May 2011
Posts: 442
Hi all, I'm Maria, and we just started TTC. We did some crazy BD'ing this month (not a bad thing!!) and now I'm on my TWW. I have another 3 days to AF (this is presuming I have a 28 day cycle). Just got off BC last month (had the 1 week requisite AF) then started TTC. Tested on Sunday and got a BFN , I've been going crazy googling 'early pregnancy signs' etc. I think y'all know the symptoms .
I want a BFP!!! And the wait is driving me NUTS!!!!
to all
Reply With Quote
Reply

Topic Tools Search this Topic
Search this Topic:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 04:43 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0