JustMommies Message Boards

JustMommies Message Boards (http://www.justmommies.com/forums/)
-   Trying to Conceive (http://www.justmommies.com/forums/f29-trying-to-conceive/)
-   -   did I O........again? (http://www.justmommies.com/forums/f29-trying-to-conceive/2637287-did-i-o-again.html)

BDmom6907 March 23rd, 2013 07:31 PM

did I O........again?
 
so looking at my chat my temp went up again and looks like i may have O again??? im so confused....

bella88 March 23rd, 2013 07:39 PM

Re: did I O........again?
 
I think you didn't O the first time tbh

It looks like you O'd yesterday to me

daolive14 March 23rd, 2013 08:23 PM

Re: did I O........again?
 
Do you normally have long cycles or O late? If not, I would guess that you did O already. Your cover line looks like it is set a bit high though. Have you tested?

Gamer_Princess March 24th, 2013 01:43 AM

Re: did I O........again?
 
Looks like you could have O'd on the 20th. What was your CM like that day? What happens when you take out the manually inputed O date?

BDmom6907 March 24th, 2013 11:40 AM

Re: did I O........again?
 
I normally don't O late I'm usually between CD 15-19. My cm was the ewcm around CD 15 and then stayed creamy. If I take out my cross hairs I put in it says I haven't O yet. I have taken tests and its a bfn I wish I would of done opk this month! My temp did go down this morning so maybe af is on her way....


All times are GMT -7. The time now is 02:49 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright © 2003-2012 JustMommies.com, All Rights Reserved.